源码论坛公告:本站是一个交流学习建站资源的社区论坛,请注意禁止发布违规信息和违法资源 【点击此处将锦尚放在桌面

源码论坛,商业源码下载,尽在锦尚中国商业源码论坛

 找回密码
 会员注册

QQ登录

只需一步,快速开始

查看: 234|回复: 0

[Mysql教程] Kettle的MySQL数据源版本问题及解决办法

[复制链接]

2709

主题

3060

帖子

9万

金币

超级版主

Rank: 8Rank: 8

积分
187418
发表于 2023-1-17 21:23:40 | 显示全部楼层 |阅读模式

这篇文章主要介绍了Kettle的MySQL数据源版本问题及解决,具有很好的参考价值,希望对大家有所帮助。如有错误或未考虑完全的地方,望不吝赐教


背景

使用Kettle创建MySQL链接时,JDBC包版本兼容问题,只能用5.1的mysql.jar包。

高版本用不了。然而,现在普遍都是8.0的MySQL版本。

原因

1.官方支持问题

如图可以看到官方支持的是MySQL-JDBC-5.1.jar。

经过测试,5.1的jar包,确实可以直接用,但是链接高版本的MySQL时会出问题。



2.MySQL曾经换过包名

有可能是因为这个问题,新的驱动包,Kettle找不到。

解决方法

1.将高版本驱动包

放在**\data-integration\lib中

2.如图配置

  1. jdbc:mysql://localhost:3368/dev?useUnicode=true&characterEncoding=utf8&zeroDateTimeBehavior=convertToNull&useSSL=true&serverTimezone=GMT%2B8

  2. com.mysql.cj.jdbc.Driver
复制代码




3.链接成功



以上为个人经验,希望能给大家一个参考,也希望大家多多支持源码论坛。

您需要登录后才可以回帖 登录 | 会员注册

本版积分规则

锦尚中国源码论坛

聚合标签|锦尚中国,为中国网站设计添动力 ( 鲁ICP备09033200号 ) |网站地图

GMT+8, 2023-2-6 01:17 , Processed in 0.109375 second(s), 25 queries .

带宽由 锦尚数据 提供 专业的数据中心

© 锦尚中国源码论坛 52jscn Inc. 非法入侵必将受到法律制裁 法律顾问:IT法律网 & 褚福省律师 锦尚爱心 版权申诉 版权与免责声明